Image Rendering Delays
Incident Report for Zenfolio
Resolved
Our team has closely monitored this incident and worked closely with our service provider refining throughput speeds for image rending and loading. We are comfortable at this stage to close out the incident, as system speeds have returned to normal. Thank you for your continued patience with us as we worked to resolve this incident fully.
Posted Oct 25, 2019 - 13:10 PDT
Update
Our engineers have continued their efforts with our service provider to make refinements to overall throughput speeds. Image rendering on existing galleries remains stable. While not optimal, please continue to keep in mind that brief rendering delays may occur on newly uploaded images. Unless needed sooner, our next update will be on Friday at approximately 1pm UTC (9am EDT / 6am PDT)
Posted Oct 24, 2019 - 06:05 PDT
Update
We continue to monitor and make fine adjustments to system resources with our service provider to ensure consistent throughput speed. The changes made yesterday did not end up achieving the result we expect for our customers, so they were reverted for the time being. Unless needed sooner, our next update will be on Thursday at approximately 1pm UTC (9am EDT / 6am PDT).
Posted Oct 23, 2019 - 05:25 PDT
Update
Our Engineers worked with our service provider yesterday to enable additional resources to improve throughput speed, which should provide gains in image rendering time and loading. We are closely monitoring these changes to ensure they have the expected result. Unless needed sooner, our next update will be on Wednesday at approximately 1pm UTC (9am EDT / 6am PDT).
Posted Oct 22, 2019 - 05:29 PDT
Update
Image rendering and system throughput speeds remained stable over the weekend. Our Engineers continue to closely work with our service provider to ensure any delays are kept to a minimum. Please continue to keep in mind there may be a short delay immediately after uploading new images. Unless needed sooner, our next update will be on Tuesday at approximately 1pm UTC (9am EDT / 6am PDT).
Posted Oct 21, 2019 - 05:58 PDT
Update
Image rendering has continued to remain stable throughout the overnight hours and into the early morning hours. Slight delays in image rendering may still be noticeable immediately after uploading, however, rendering slowness has been kept to a minimum, with no significant rendering delays. Throughout the weekend, we will continue to strongly monitor performance. Unless needed sooner, our next update will be on Monday at approximately 1pm UTC (9am EDT / 6am PDT).
Posted Oct 18, 2019 - 05:36 PDT
Update
Image loading and rendering stability was strong overnight. Around 2am UTC there was a degradation of throughput speed with our service provider, which they quickly resolved. Our next update will be Friday at approximately 1pm UTC (9am EDT / 6am PDT) unless an updated is needed before then.
Posted Oct 17, 2019 - 05:45 PDT
Update
Throughput with our service provider continues to be degraded. There may be occasional delays with image loading, but overall the system has been stable throughout the day. We appreciate your continued patience while we work to restore peak system performance. Our next update will be Thursday at approximately 1pm UTC (9am EDT / 6am PDT).
Posted Oct 16, 2019 - 16:34 PDT
Update
There were no changes in the system status overnight. Our Engineers continue to monitor the platform and make adjustments, as necessary, to help remedy any throughput delays with our service provider. Our next update will be approximately 11pm UTC (7pm EDT, 4pm PDT).
Posted Oct 16, 2019 - 05:39 PDT
Update
The system continues to be stable, although not at peak throughput. Late this evening UTC time, we noticed reports of some upload delays. Our teams adjusted server resources to remedy this, which quickly resolved the issue. Since then the system has been performing well. We appreciate your continued patience. Our next update will be Wednesday at approximately 1pm UTC (9am EDT / 6am PDT).
Posted Oct 15, 2019 - 16:35 PDT
Update
System stability has remained strong in the overnight hours. However, we continue to work with our service provider to restore image rendering and page loading speeds to their normal operating levels. Our next update will be approximately 11pm UTC (7pm EDT, 4pm PDT) on Tuesday.
Posted Oct 15, 2019 - 05:21 PDT
Update
Our Engineers continue to closely monitor system throughput and loading times. Around 7pm UTC our own monitors detected issues with pages not loading, and this was also seen by customer reports. Our teams worked quickly to remedy the cause of the issue to restore service. We are working diligently with our service provider on maximizing performance and restoring speeds to their normal levels. We greatly appreciate your continued patience. Our next update will be approximately 1pm UTC (9am EDT, 6am PDT) on Tuesday.
Posted Oct 14, 2019 - 14:50 PDT
Update
Beginning around 2pm UTC on Sunday, Oct. 13 we noticed another increase in rendering delays. Engineers quickly worked with our service provider to make additional adjustments to restore performance. No other delays were detected in the overnight hours. We are seeing expected loading times overall across the platform but will continue to monitor. Thank you for your continued patience. Our next update will be at approximately 11pm UTC (7pm EDT, 4pm PDT).
Posted Oct 14, 2019 - 05:53 PDT
Monitoring
Rendering speeds have continued to remain stable throughout the overnight hours. We are still seeing great improvement overall with image rendering on newly uploaded images, older images, and order image thumbnail previews. Unless needed sooner, our next update will be Monday, at approximately 1pm UTC (9am EDT / 6am PDT)
Posted Oct 13, 2019 - 06:32 PDT
Update
Engineers have continued their efforts to work with our service provider to restore image rendering across both newer and older galleries. We are noticing significant improvement, and continue to monitor the situation closely.
Posted Oct 12, 2019 - 17:21 PDT
Identified
The issue affecting image rendering has been identified, and originates from a storage location at our primary storage provider. Our engineers have implemented a solution that will reduce rendering times for newly uploaded images, however, we continue to see delays with older galleries, image thumbnail previews on orders, and videos. We will continue to monitor and provide updates throughout the weekend.
Posted Oct 12, 2019 - 10:47 PDT
Investigating
Engineers are currently investigating reports of slow image rendering, on both newly uploaded galleries and galleries that have been uploaded prior to today, October 12th. This issue is affecting image thumbnail previews on orders as well. Thank you for your patience while we work to resolve this.
Posted Oct 12, 2019 - 07:24 PDT
This incident affected: Zenfolio Classic (Websites, Content Rendering).