Intermittent Upload Errors

Incident Report for Zenfolio

Resolved

After monitoring the platform for several hours we have not seen any additional upload errors. Thank you for your understanding.
Posted May 29, 2026 - 05:52 PDT

Monitoring

We have been able to make updates to the service and we are seeing Uploads perform as expected.

We will continue to monitor this issue to make sure it has been solved.
Posted May 28, 2026 - 16:46 PDT

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 13:22 PDT

Investigating

We are receiving reports that some photographers are seeing intermittent errors when uploading. Our engineers are actively investigating the cause of the issue. We thank you for your patience.
Posted May 28, 2026 - 13:22 PDT
This incident affected: Zenfolio Classic (Upload).