Zenfolio.com is currently down, but Photographer websites are not affected

Incident Report for Zenfolio

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 15:57 PDT

Monitoring

We have been able to fix the issue with Zenfolio.com and it is now back up and running as expected.

Once again, there was never any issue with Zenfolio hosted photographer sites.
Posted Sep 11, 2025 - 15:12 PDT

Investigating

Our Zenfolio Home Page located at Zenfolio.com is currently unavailable.

We are investigating and will update once we know more.

Please note that any Zenfolio hosted photographer sites are not affected and are working as intended
Posted Sep 11, 2025 - 14:50 PDT
This incident affected: Zenfolio Home Page.