Investigating some emails not being delivered

Incident Report for Zenfolio

Resolved

The issue was solved and all emails are now being delivered as expected.
Posted Nov 04, 2024 - 10:09 PST

Investigating

We have reports of some emails being blocked by email hosts.
We are working with them as a highest priority to make sure all emails are able to be delivered
Posted Oct 29, 2024 - 15:16 PDT
This incident affected: Zenfolio (Email Communication).