Zenfolio Classic Slowness

Incident Report for Zenfolio

Resolved

The fixes have solved the issue and we are closing this incident.
Posted May 05, 2026 - 15:04 PDT

Monitoring

We have implemented a fix for Classic Zenfolio slowness. We are monitoring and will update as we have more information
Posted May 05, 2026 - 13:32 PDT

Identified

We have noticed slowness of the Classic Platform. The issue has been identified and we are working to resolve the issue.
Posted May 05, 2026 - 10:56 PDT
This incident affected: Zenfolio Classic (Websites, Download, Content Rendering, Login, Search, API).