NextZen gallery settings unable to be changed

Incident Report for Zenfolio

Resolved

This incident has now been resolved. Thank you for your understanding.
Posted Sep 02, 2026 - 14:32 PDT

Monitoring

Our engineers have implemented a fix to address issues related to modifying gallery settings and client download issues. If you see any lingering issues within your account please contact support@zenfolio.com
Posted Sep 02, 2026 - 11:10 PDT

Investigating

Our engineers are currently investigating reports of NextZen users being unable to adjust gallery settings and permissions. We appreciate your patience while we actively work to implement a fix for the issue.
Posted Sep 02, 2026 - 08:37 PDT
This incident affected: Zenfolio (Websites, Upload, Download, Content Rendering).