After 24 hours of monitoring, the Classic platform remains stable with no additional reports of site slowness. We appreciate your patience and understanding!
Posted Jul 30, 2025 - 08:52 PDT
Update
Our Engineers identified the issue with help from our service provider and we have put a fix in place. Zenfolio sites are now loading as expected.
We continue to monitor the system and will provide an update tomorrow.
Posted Jul 29, 2025 - 14:50 PDT
Monitoring
Our Engineers identified the issue with help from our service provider and we have put a fix in place. Zenfolio sites are now loading as expected.
For the next 4 hours we will continue to monitor this issue and make adjustments as needed.
Posted Jul 29, 2025 - 11:36 PDT
Investigating
We’re currently investigating an issue affecting Classic Zenfolio websites, including site outages and “Service Unavailable” errors.
Our engineering team is actively working on this as a top priority and we’ll provide updates as progress is made toward a resolution.
Thank you for your patience and understanding!
Posted Jul 29, 2025 - 05:40 PDT
This incident affected: Zenfolio Classic (Websites).