Intermittent issues with Error 500 message
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 22, 2017 - 07:46 PST
Investigating
Our engineers are investigating reports of intermittent issues receiving Error 500 messages
Posted 5 months ago. Feb 22, 2017 - 04:32 PST