A database issue being investigated
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted about 2 months ago. Mar 30, 2017 - 20:22 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Mar 30, 2017 - 20:01 PDT
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Mar 30, 2017 - 19:08 PDT