Slow image loading
Incident Report for Zenfolio
Resolved
We've received no further reports of slowness with images loading at this time. Our Engineers will continue monitoring things, and we'll provide updates, as needed.
Posted Jul 09, 2018 - 07:35 PDT
Investigating
We continue to receive reports of slow image loading in galleries. Our Engineering team is working on finding a solution as a top priority, and we'll update this page once we have more information. Our apologies for the continued inconvenience.
Posted Jul 08, 2018 - 16:45 PDT
This incident affected: Zenfolio Classic (Websites).