Some users experiencing errors when navigating their site
Incident Report for Zenfolio
Resolved
The Engineers were able to identify the issue and get it quickly resolved, and apologies for any inconvenience.
Posted 5 months ago. Dec 15, 2016 - 22:05 PST
Investigating
We are aware of some users are experiencing errors when working with the site, and the engineers are aware and working on a resolution
Posted 5 months ago. Dec 15, 2016 - 21:20 PST