www.zenfolio.com is not loading
Incident Report for Zenfolio
Resolved
After monitoring the fix put in place for www.zenfolio.com not loading, we're not seeing any further issues. Thank you for your patience as we worked with our service provider to remedy.
Posted Mar 05, 2020 - 10:43 PST
Monitoring
Our Engineers identified the issue with our service provider and put in place a fix, which they are monitoring. Thank you for your patience.
Posted Mar 05, 2020 - 07:34 PST
Investigating
While all customer websites are operational, www.zenfolio.com is currently not loading. Our engineers are investigating the cause. If you need to log in to your account, you can do so at this page: https://secure.zenfolio.com/zf/login.aspx
Posted Mar 05, 2020 - 03:56 PST
This incident affected: Zenfolio Home Page.