Download issues via some browser/devices
Incident Report for Zenfolio
Resolved
Our engineers have resolved this issue. Thank you for your patience.
Posted Apr 01, 2020 - 15:30 PDT
Investigating
Our Engineers are looking into issues with download requests of images on mobile and some desktop browsers. The image will often fail to download and will display a blank 'Error 503' page or similar messaging. We are looking into this as a high priority, and your patience is greatly appreciated while we work to resolve.
Posted Apr 01, 2020 - 08:55 PDT
This incident affected: Zenfolio Classic (Websites, Content Rendering).