Some original file downloads not completing
Incident Report for Zenfolio
Resolved
The download issue has been resolved.
Posted 8 months ago. Nov 24, 2016 - 03:56 PST
Identified
Engineers have identified the issue and are currently implementing a fix.
Posted 8 months ago. Nov 23, 2016 - 18:16 PST
Investigating
Our Engineers are looking into reports of some original file downloads not completing. Our apologies for any inconvenience, and we'll keep this updated as we know more. Thank you for your patience.
Posted 8 months ago. Nov 23, 2016 - 15:58 PST