Some errors being reported
Incident Report for Zenfolio
Resolved
The issue has been addressed and all functionality has been restored. Thank you for your patience while we got this resolved.
Posted 21 days ago. Jul 27, 2017 - 18:31 PDT
Investigating
We are aware of some errors being reported when navigating through Zenfolio. We are working on identifying the issue and getting it resolved asap
Posted 21 days ago. Jul 27, 2017 - 18:02 PDT