Slow Site Performance
Incident Report for Zenfolio
Resolved
The issue has been resolved.
Posted 3 months ago. May 04, 2017 - 15:12 PDT
Monitoring
We have identified the cause and are monitoring the performance as it improves.
Posted 3 months ago. May 04, 2017 - 14:41 PDT
Investigating
Our engineers are investigating reports of slow site performance.
Posted 3 months ago. May 04, 2017 - 14:21 PDT