Some site pages not loading
Incident Report for Zenfolio
Resolved
The issue preventing Zenfolio's homepage from loading has been resolved. Thank you for your patience while we worked with our service providers to correct.
Posted 6 months ago. Jun 09, 2017 - 11:54 PDT
Identified
This issue preventing Zenfolio's homepage from loading has been identified, and we are working with our service providers to get it resolved. Your Zenfolio site is unaffected, and you can login to it here: https://goo.gl/3bJ3i
Posted 6 months ago. Jun 09, 2017 - 09:27 PDT
Investigating
Our engineers are looking into reports of some site pages and zenfolio.com not loading. We will provide an update once we have more information. Thanks for your patience.
Posted 6 months ago. Jun 09, 2017 - 07:58 PDT