Image Loading
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 30, 2016 - 08:09 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Dec 30, 2016 - 06:47 PST
Investigating
We are investigating reports of some images not loading.
Posted 5 months ago. Dec 30, 2016 - 05:46 PST