Zenfolio.com not loading
Incident Report for Zenfolio
Resolved
Zenfolio.com is back up and loading normally. Thank you for your patience.
Posted Nov 12, 2018 - 05:29 PST
Investigating
Our homepage of zenfolio.com is currently not loading. We are looking into this with our service provider. Our apologies for the inconvenience. However, no Zenfolio customer site are affected. If you’re unable to login to your Zenfolio account, please use this link: https://secure.zenfolio.com/zf/login.aspx
Posted Nov 12, 2018 - 05:14 PST
This incident affected: Zenfolio Home Page.