Sites down or unresponsive
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 23, 2016 - 05:36 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Nov 21, 2016 - 13:21 PST
Investigating
Our engineers are aware that some sites may be down, slow, or unresponsive. We will keep this updated as we know more.
Posted about 1 year ago. Nov 21, 2016 - 08:50 PST