Intermittent Site Errors
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted Nov 11, 2018 - 06:26 PST
Identified
Our Engineers have identified the issue and are putting in place a fix to resolve it. Thank you for your patience.
Posted Nov 11, 2018 - 05:16 PST
Investigating
Our engineers are looking into reports of intermittent site errors. We will keep this page updated as we have more information.
Posted Nov 11, 2018 - 04:33 PST
This incident affected: Zenfolio Classic (Websites) and Support Center.