Gallery Invites Delayed
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 25, 2016 - 11:05 PDT
Investigating
Our engineers are investigating issues with gallery invites being delayed. We will update as we have more information.
Posted about 1 year ago. Aug 25, 2016 - 07:11 PDT