Errors when performing some photo-related tasks
Incident Report for Zenfolio
Resolved
We have resolved the issue pertaining to photo ID's that was creating the error.

Apologies for any inconvenience.
Posted 11 months ago. Jan 03, 2017 - 16:04 PST
Investigating
We are currently looking into error reports when uploading and viewing photos. Thank you for your patience.
Posted 11 months ago. Jan 03, 2017 - 13:22 PST