Some sites slow or non-responsive
Incident Report for Zenfolio
Resolved
Our engineers have resolved the most recent incident and all sites are operating normally. Thank you for your patience.
Posted about 1 year ago. May 01, 2016 - 09:31 PDT
Update
Our engineers are diagnosing the cause of the issue and working to resolve this asap. Thank you for your continued patience
Posted about 1 year ago. May 01, 2016 - 08:08 PDT
Investigating
Our engineers are investigating reports of some sites being slow or non-responsive - we will keep you updated
Posted about 1 year ago. May 01, 2016 - 05:50 PDT