Gallery Invites Delayed
Incident Report for Zenfolio
Resolved
The Gallery Invite delay has been resolved with our email server, and emails are being sent correctly. Thanks for your patience.
Posted about 1 year ago. Aug 25, 2016 - 16:27 PDT
Investigating
Our engineers are investigating issues with gallery invites being delayed. We will update as we have more information.
Posted about 1 year ago. Aug 25, 2016 - 11:42 PDT