Slower than normal uploads and incomplete downloads
Incident Report for Zenfolio
Resolved
We have monitored the upload and download performance through our peak holiday season, and we made many improvements to mitigate any delays our users were experiencing. In the new year, we will take all of our learnings and continue to improve our platform, enhance stability, and improve the overall user experience. Thank you for your continued patience while we worked through these complicated issues.
Posted 7 months ago. Jan 07, 2019 - 10:59 PST
Update
We continue to monitor upload and download performance and make any necessary improvements needed. Your continued patience while we work to resolve any delays is greatly appreciated.
Posted 8 months ago. Dec 16, 2018 - 18:19 PST
Update
Our teams continue to monitor upload and download speeds, as well as make daily improvements to limit any delays. Thank you for your continued patience.
Posted 9 months ago. Dec 07, 2018 - 12:45 PST
Update
While majority of upload issues have been resolved, we are aware that a few users still experience slower than normal upload and download speeds. We will continue to improve and monitor the platform until uploads and downloads are as fast and efficient as possible. We thank you for your continued patience.
Posted 9 months ago. Nov 26, 2018 - 14:25 PST
Update
The image rendering issue issue has been resolved. We will continue to improve and monitor the platform to ensure uploads an downloads are as fast and efficient as possible. We thank you once again for your continued patience.
Posted 9 months ago. Nov 22, 2018 - 00:24 PST
Update
While we continue to make improvements to upload speeds and monitor their impact, we are aware that some users have seen delays in image rendering as well. We are working on this as a top priority, and thank you for your continued patience.
Posted 9 months ago. Nov 21, 2018 - 14:12 PST
Update
To resolve the residual upload issues some users are experiencing, our engineers continue to make additional enhancements in order to make uploads faster and more efficient. We will continue to monitor the impact of the improvements, and we will continue to be proactive in our approach.
Posted 9 months ago. Nov 20, 2018 - 12:45 PST
Monitoring
Our engineers have taken a multi-directional approach to alleviating the recent upload issues via increasing server capacity as well as carefully balancing the load across our servers. Most users are uploading without issue, but we continue to watch performance closely, especially as demand increases Monday and Tuesday of this week. Thank you for your continued patience.
Posted 9 months ago. Nov 19, 2018 - 13:51 PST
Investigating
While the fixes implemented by the engineers resolved many upload issues, there are still some users experiencing slow uploads and connection errors. We are working to identify the root cause of these remaining issues. Thank you for your continued patience.
Posted 9 months ago. Nov 13, 2018 - 11:24 PST
Update
We have completed the brief scheduled maintenance, and are monitoring all systems. Thank you for your continued patience.
Posted 10 months ago. Nov 06, 2018 - 20:29 PST
Update
We will be performing maintenance on Tuesday, Nov. 6 at 8pm PST to address the recent delays in image generation. At this time, some users may experience some images not loading in galleries, but they will will appear once the maintenance is complete. Thanks for your patience while we address the ongoing issue.
Posted 10 months ago. Nov 06, 2018 - 19:45 PST
Update
Our teams have been working diligently to resolve any delays with uploads, downloads, and image generation. While temporary fixes were put in place, they did not fully resolve the delays. As our Engineers performed a deep dive into the issues, a root cause was identified, and they’ve been working to put in a permanent fix. Our sincerest apologies for the inconvenience as we work through to a full resolution.
Posted 10 months ago. Nov 05, 2018 - 10:05 PST
Update
Our engineers made improvements to return upload speeds to normal on Friday, Oct. 26. However, some users are still reporting delays or stuck uploads. We are continuing to look into these and put in a place a permanent solution. Our apologies for any inconvenience.
Posted 10 months ago. Oct 30, 2018 - 07:08 PDT
Monitoring
Our engineers have made the necessary improvements to return the upload speeds to normal. We will continue to monitor these to ensure that there are no residual issues
Posted 10 months ago. Oct 26, 2018 - 19:25 PDT
Update
The downloads are now working correctly, apologies for the inconvenience. We are still addressing the slow upload issue and thank you for your continued patience This issue is still our top priority.
Posted 10 months ago. Oct 26, 2018 - 15:47 PDT
Update
We are continuing to investigate this issue, and it is our top priority. Thank you for your continued patience.
Posted 10 months ago. Oct 26, 2018 - 13:57 PDT
Investigating
We are looking into reports of users experiencing longer than normal upload times, and some users unable to complete downloads. Thank you for your patience.
Posted 10 months ago. Oct 26, 2018 - 09:18 PDT
This incident affected: Image Processing.