Gallery invites delayed
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 24, 2016 - 12:29 PDT
Investigating
Our engineers are aware of delivery of gallery invites being delayed. All other aspects of the site are operational. We will provide updates as information is available.
Posted over 1 year ago. Aug 24, 2016 - 08:17 PDT