Email Support
Incident Report for Zenfolio
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 22, 2016 - 15:35 PDT
Investigating
Inbound and Outbound emails from Customer Support are currently delayed. Our engineers are aware of the issue and working on it with the highest priority.
Posted over 1 year ago. Jun 22, 2016 - 04:13 PDT